<!doctype html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
	<link rel="profile" href="https://gmpg.org/xfn/11">

	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script type="text/javascript">
var trackScrolling=false;
var trackScrollingPercentage=false;
var ScrollingPercentageNumber=25;
var stLogInterval=10*1000;
var cutOffTime=900;
var trackNoEvents=false;
var trackNoMaxTime=false;
var docTitle='Guy LaFleur&#8217;s 70th birthday';
</script>

	<!-- This site is optimized with the Yoast SEO plugin v17.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Guy LaFleur&#039;s 70th birthday</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=PT%20Sans%3A300%2C300i%2C400%2C400i%2C500%2C500i%2C700%2C700i&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=PT%20Sans%3A300%2C300i%2C400%2C400i%2C500%2C500i%2C700%2C700i&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=PT%20Sans%3A300%2C300i%2C400%2C400i%2C500%2C500i%2C700%2C700i&#038;display=swap" /></noscript>
	<link rel="canonical" href="https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Guy LaFleur&#039;s 70th birthday" />
	<meta property="og:description" content="Guy LaFleur can&#8217;t believe it. He celebrates his 70th birthday tomorrow. Like everyone else growing up, he can&#8217;t believe it. A chic from Denis Botvin won&#8217;t shake him up anymore.&hellip;" />
	<meta property="og:url" content="https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/" />
	<meta property="og:site_name" content="Vaughan Today" />
	<meta property="article:published_time" content="2021-09-19T07:59:04+00:00" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Virginia Whitehead" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="5 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.vaughantoday.ca/#organization","name":"Vaughan Today","url":"https://www.vaughantoday.ca/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://www.vaughantoday.ca/#logo","inLanguage":"en-US","url":"https://www.vaughantoday.ca/wp-content/uploads/2020/11/Vaughan-Today.png","contentUrl":"https://www.vaughantoday.ca/wp-content/uploads/2020/11/Vaughan-Today.png","width":361,"height":190,"caption":"Vaughan Today"},"image":{"@id":"https://www.vaughantoday.ca/#logo"}},{"@type":"WebSite","@id":"https://www.vaughantoday.ca/#website","url":"https://www.vaughantoday.ca/","name":"Vaughan Today","description":"Complete News World","publisher":{"@id":"https://www.vaughantoday.ca/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.vaughantoday.ca/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/#primaryimage","inLanguage":"en-US","url":"https://www.vaughantoday.ca/wp-content/uploads/2021/09/Guy-LaFleurs-70th-birthday.jpg","contentUrl":"https://www.vaughantoday.ca/wp-content/uploads/2021/09/Guy-LaFleurs-70th-birthday.jpg","width":1200,"height":494,"caption":"Guy LaFleur's 70th birthday"},{"@type":"WebPage","@id":"https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/#webpage","url":"https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/","name":"Guy LaFleur's 70th birthday","isPartOf":{"@id":"https://www.vaughantoday.ca/#website"},"primaryImageOfPage":{"@id":"https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/#primaryimage"},"datePublished":"2021-09-19T07:59:04+00:00","dateModified":"2021-09-19T07:59:04+00:00","breadcrumb":{"@id":"https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/"]}]},{"@type":"BreadcrumbList","@id":"https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Guy LaFleur&#8217;s 70th birthday"}]},{"@type":["Article","NewsArticle"],"@id":"https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/#article","isPartOf":{"@id":"https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/#webpage"},"author":{"@id":"https://www.vaughantoday.ca/#/schema/person/1ada04d7b657a7e530b7f1a039482b99"},"headline":"Guy LaFleur&#8217;s 70th birthday","datePublished":"2021-09-19T07:59:04+00:00","dateModified":"2021-09-19T07:59:04+00:00","mainEntityOfPage":{"@id":"https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/#webpage"},"wordCount":1012,"commentCount":0,"publisher":{"@id":"https://www.vaughantoday.ca/#organization"},"image":{"@id":"https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/#primaryimage"},"thumbnailUrl":"https://www.vaughantoday.ca/wp-content/uploads/2021/09/Guy-LaFleurs-70th-birthday.jpg","articleSection":["sport"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/#respond"]}]},{"@type":"Person","@id":"https://www.vaughantoday.ca/#/schema/person/1ada04d7b657a7e530b7f1a039482b99","name":"Virginia Whitehead","image":{"@type":"ImageObject","@id":"https://www.vaughantoday.ca/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/e898f11d4cadd2326f299ae15120fd1c?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/e898f11d4cadd2326f299ae15120fd1c?s=96&d=mm&r=g","caption":"Virginia Whitehead"},"description":"\"Pop culture maven. Unapologetic student. Avid introvert. Gamer. Problem solver. Tv fanatic.\""}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Vaughan Today &raquo; Feed" href="https://www.vaughantoday.ca/feed/" />
<link rel="alternate" type="application/rss+xml" title="Vaughan Today &raquo; Comments Feed" href="https://www.vaughantoday.ca/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Vaughan Today &raquo; Guy LaFleur&#8217;s 70th birthday Comments Feed" href="https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.vaughantoday.ca/wp-includes/css/dist/block-library/style.min.css?ver=5.8.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://www.vaughantoday.ca/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://www.vaughantoday.ca/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp_automatic_gallery_style-css'  href='https://www.vaughantoday.ca/wp-content/plugins/wp-automatic/css/wp-automatic.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-style-css'  href='https://www.vaughantoday.ca/wp-content/themes/mags-pro/assets/library/bootstrap/css/bootstrap.min.css?ver=4.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-style-css'  href='https://www.vaughantoday.ca/wp-content/themes/mags-pro/assets/library/font-awesome/css/all.min.css?ver=5.7.2' type='text/css' media='all' />

<link rel='stylesheet' id='owl-carousel-css'  href='https://www.vaughantoday.ca/wp-content/themes/mags-pro/assets/library/owl-carousel/owl.carousel.min.css?ver=2.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='mags-style-css'  href='https://www.vaughantoday.ca/wp-content/themes/mags-pro/style.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.vaughantoday.ca/wp-content/plugins/jetpack/css/jetpack.css?ver=10.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.vaughantoday.ca/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' data-cfasync='true' id='jquery-core-js' defer></script>

<script type='text/javascript' id='cfmonitor-js-extra'>
/* <![CDATA[ */
var cfmonitor = {"client_ip":"107.23.218.4","max_clicks":"2","clicks":"0","is_blocked":"0","customclass":"","disablead":"false","currentURL":"\/guy-lafleurs-70th-birthday\/","debug":"true","caching":"1","ajaxurl":"https:\/\/www.vaughantoday.ca\/wp-admin\/admin-ajax.php","nonce":"e9dcc6c0c0"};
/* ]]> */
</script>


<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.vaughantoday.ca/wp-content/themes/mags-pro/assets/js/html5.js?ver=3.7.3' data-cfasync='true' id='html5-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="https://www.vaughantoday.ca/wp-json/" /><link rel="alternate" type="application/json" href="https://www.vaughantoday.ca/wp-json/wp/v2/posts/15980" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.vaughantoday.ca/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.vaughantoday.ca/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.1" />
<link rel='shortlink' href='https://www.vaughantoday.ca/?p=15980' />
<meta name="framework" content="Redux 4.2.14" /><link rel="preconnect" href="https://cdnjs.cloudflare.com"><script data-ad-client="ca-pub-3059805454647315" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<script data-ad-client="ca-pub-7561420867844318" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-2988081137721490" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-5395246548978360" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-8852359589177633" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-9373527821382765" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-7549848403777038" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-1002222987041100" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-2286843017297526" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-8512117689471250" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-6339419063394600" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-7055430779784404" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-1282998403883329" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-1959342430339023" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-8681597530161456" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-4340007952103971" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-7378220154980429" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-2144735531368922" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-4376846659655258" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-9782305711909283" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-2913700801068620" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-1455291460780948" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-5899356243834020" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-1489419147573258" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-1453234738179354" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-1760846938532726" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-8790038358560322" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-4332103873892195" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-5061020171259996" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-8857444583171744" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<meta name="google-site-verification" content="f9l-gbC69XXxKdtmAFzXlFeruLZLpViitlar-RIx7QQ" /><script data-ad-client="ca-pub-9373527821382765" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><link rel="pingback" href="https://www.vaughantoday.ca/xmlrpc.php">
	<style type="text/css">
				@media (min-width: 768px) {
				}
		@media (min-width: 992px) {
					}
		@media (min-width: 768px) and (max-width: 991px) {
					}
		/* Color Scheme > links */
			::selection {
				background-color: #9651cc;
				color: #fff;
			}
			::-moz-selection {
				background-color: #9651cc;
				color: #fff;
			}
			a,
			a:hover,
			a:focus,
			a:active,
			.entry-title a:hover,
			.entry-title a:focus,
			.entry-title a:active,
			.post-boxed .entry-title a:hover,
			.site-footer .widget-area .post-boxed .entry-title a:hover,
			.entry-meta a:hover,
			.entry-meta a:focus,
			.post-boxed .entry-meta a:hover,
			.site-footer .widget-area .post-boxed .entry-meta a:hover,
			.entry-meta .tag-links a,
			.nav-links a:hover,
			.widget ul li a:hover,
			.widget_categories .current-cat a,
			.comment-metadata a.comment-edit-link,
			.widget_nav_menu ul li.current_page_item > a,
			.widget_nav_menu ul li.current_page_ancestor > a,
			.widget_nav_menu ul li.current-menu-item > a,
			.widget_nav_menu ul li.current-menu-ancestor > a,
			.widget_pages ul li.current_page_item > a,
			.widget_pages ul li.current_page_ancestor > a,
			.widget_tag_cloud a:hover,
			.woocommerce.widget_product_categories ul.product-categories .cat-parent > a,
			.woocommerce.widget_product_categories ul.product-categories .current-cat a,
			.woocommerce .star-rating,
			.woocommerce .star-rating:before {
				color: #9651cc;
			}
		/* Color Scheme > Navigation */
			.navbar {
				background-color: #9651cc;
			}
			.main-navigation li ul li:hover > a,
			.main-navigation li ul li.current-menu-item > a,
			.main-navigation li ul li.current-menu-ancestor > a,
			.main-navigation ul li li.current_page_item > a,
			.main-navigation li ul li.current_page_ancestor > a {
				color: #9651cc;
			}
			@media (max-width: 991px) {
				.main-navigation ul li.current_page_item > a,
				.main-navigation ul li.current_page_ancestor > a,
				.main-navigation ul li.current-menu-item > a,
				.main-navigation ul li.current-menu-ancestor > a,
				.main-navigation ul li a:hover,
				.main-navigation ul li a:focus,
				.main-navigation ul li:hover > a,
				.main-navigation li ul li:hover > a,
				.main-navigation li ul li.current-menu-item > a,
				.main-navigation li ul li.current-menu-ancestor > a,
				.main-navigation ul li li.current_page_item > a,
				.main-navigation li ul li.current_page_ancestor > a {
					color: #9651cc;
				}
			}
		/* Color Scheme > Buttons */
			.btn-theme,
			.btn-outline-theme:hover,
			.btn-outline-info:not(:disabled):not(.disabled).active,
			.btn-outline-info:not(:disabled):not(.disabled):active,
			.show > .btn-outline-info.dropdown-toggle,
			input[type="reset"],
			input[type="button"],
			input[type="submit"],
			button[type="submit"],
			.back-to-top a,
			#bbpress-forums button,
			div.bbp-submit-wrapper button,
			.bbp_widget_login .button,
			.navigation.pagination .current,
			.navigation.pagination a:hover,
			.page-links span,
			.page-links a:hover span,
			.woocommerce #respond input#submit,
			.woocommerce a.button,
			.woocommerce button.button,
			.woocommerce input.button,
			.woocommerce #respond input#submit.alt,
			.woocommerce a.button.alt,
			.woocommerce button.button.alt,
			.woocommerce input.button.alt,
			.woocommerce-cart .wc-proceed-to-checkout a.checkout-button,
			.woocommerce input.button:disabled,
			.woocommerce input.button:disabled[disabled],
			.woocommerce input.button:disabled:hover,
			.woocommerce input.button:disabled[disabled]:hover,
			.woocommerce button.button:disabled,
			.woocommerce button.button:disabled[disabled],
			.woocommerce button.button.alt.disabled,
			.woocommerce button.button.alt.disabled:hover,
			.woocommerce span.onsale,
			.woocommerce .widget_price_filter .ui-slider .ui-slider-range,
			.woocommerce .widget_price_filter .ui-slider .ui-slider-handle {
				background-color: #9651cc;
			}
			.btn-outline-theme {
				border-color: #9651cc;
			}
			.btn-outline-theme,
			.btn-outline-theme a,
			.navigation.post-navigation .nav-links a:hover {
				color: #9651cc;
			}
		/* Color Scheme > Elements */
			.theme-color,
			.format-quote blockquote:before {
				color: #9651cc;
			}
			.theme-bg-color,
			.post.sticky .entry-header:before,
			.hentry.sticky .entry-header:before,
			.widget_calendar #wp-calendar tbody td#today {
				background-color: #9651cc;
			}
		/* Elements Color > Top Bar */
			.info-bar,
			.info-bar .infobar-links ul {
				background-color: #9651cc;
			}
			</style>

		<style type="text/css">
					.site-title,
			.site-description {
				position: absolute;
				clip: rect(1px, 1px, 1px, 1px);
			}
				</style>
		<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
	<style type="text/css">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</style><link rel="icon" href="https://www.vaughantoday.ca/wp-content/uploads/2020/11/Vaughan-Today-Favicon-150x110.png" sizes="32x32" />
<link rel="icon" href="https://www.vaughantoday.ca/wp-content/uploads/2020/11/Vaughan-Today-Favicon.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.vaughantoday.ca/wp-content/uploads/2020/11/Vaughan-Today-Favicon.png" />
<meta name="msapplication-TileImage" content="https://www.vaughantoday.ca/wp-content/uploads/2020/11/Vaughan-Today-Favicon.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>

<body data-rsssl=1 class="post-template-default single single-post postid-15980 single-format-standard custom-background wp-custom-logo theme-body group-blog">

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
	
	<header id="masthead" class="site-header">
					<div class="info-bar infobar-links-on">
				<div class="container">
					<div class="row gutter-10">
						<div class="col-12 col-sm contact-section">
							<div class="date">
								<ul><li>Sunday, September 19, 2021</li></ul>
							</div>
						</div><!-- .contact-section -->

													<div class="col-lg-auto infobar-links order-lg-2">
								<button class="infobar-links-menu-toggle">Responsive Menu</button>
								<ul class="clearfix"><li id="menu-item-2850" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2850"><a href="https://www.vaughantoday.ca/about-us/">About Us</a></li>
<li id="menu-item-2849" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2849"><a href="https://www.vaughantoday.ca/dmca/">DMCA</a></li>
<li id="menu-item-2851" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2851"><a href="https://www.vaughantoday.ca/contact-form/">Contact Form</a></li>
<li id="menu-item-2873" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-2873"><a href="https://www.vaughantoday.ca/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-2848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2848"><a href="https://www.vaughantoday.ca/editorial-policy/">Editorial Policy</a></li>
</ul>							</div><!-- .infobar-links -->
											</div><!-- .row -->
          		</div><!-- .container -->
        	</div><!-- .infobar -->
        			<div class="navbar-head" >
				<div class="container">
					<div class="row align-items-center justify-content-lg-between">
						<div class="col-auto site-branding navbar-brand">
							<a href="https://www.vaughantoday.ca/" class="custom-logo-link" rel="home"><img width="361" height="190" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20361%20190'%3E%3C/svg%3E" class="custom-logo" alt="Vaughan Today" data-lazy-srcset="https://www.vaughantoday.ca/wp-content/uploads/2020/11/Vaughan-Today.png 361w, https://www.vaughantoday.ca/wp-content/uploads/2020/11/Vaughan-Today-300x158.png 300w" data-lazy-sizes="(max-width: 361px) 100vw, 361px" data-lazy-src="https://www.vaughantoday.ca/wp-content/uploads/2020/11/Vaughan-Today.png" /><noscript><img width="361" height="190" src="https://www.vaughantoday.ca/wp-content/uploads/2020/11/Vaughan-Today.png" class="custom-logo" alt="Vaughan Today" srcset="https://www.vaughantoday.ca/wp-content/uploads/2020/11/Vaughan-Today.png 361w, https://www.vaughantoday.ca/wp-content/uploads/2020/11/Vaughan-Today-300x158.png 300w" sizes="(max-width: 361px) 100vw, 361px" /></noscript></a>							<div class="site-title-wrap">
																	<h2 class="site-title"><a class="site-title-link" href="https://www.vaughantoday.ca/" rel="home">Vaughan Today</a></h2>
																	<p class="site-description">Complete News World</p>
															</div><!-- .site-title-wrap -->
						</div><!-- .site-branding .navbar-brand -->
											</div><!-- .row -->
				</div><!-- .container -->
			</div><!-- .navbar-head -->
				<nav class="navbar navbar-expand-lg" id="sticky-navigation-bar">
			<div class="container navbar-header-container">

				
				<div class="container navigation-icons-wrap justify-content-between d-lg-none">
					<button class="navbar-toggler menu-toggle" type="button" data-toggle="collapse" data-target="#navbarCollapse" aria-controls="navbarCollapse" aria-expanded="false" aria-label="Toggle navigation"></button>
					<span class="search-toggle"></span>
				</div><!-- .navigation-icons-wrap -->

				
				<div class="navbar-main">
					<span class="search-toggle"></span>
					<div class="search-block off">
						<div class="container">
							<form action="https://www.vaughantoday.ca/" method="get" class="search-form">
	<label class="assistive-text"> Search </label>
	<div class="input-group">
		<input type="search" value="" placeholder="Search" class="form-control s" name="s">
		<div class="input-group-prepend">
			<button class="btn btn-theme">Search</button>
		</div>
	</div>
</form><!-- .search-form -->
						</div><!-- .container -->
					</div><!-- .search-box -->
					<div class="collapse navbar-collapse" id="navbarCollapse">
						<div id="site-navigation" class="main-navigation nav-uppercase" role="navigation">
							<ul class="nav-menu navbar-nav"><li id="menu-item-530" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-530"><a href="https://www.vaughantoday.ca">Home</a></li>
<li id="menu-item-531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-531"><a href="https://www.vaughantoday.ca/top-news/">Top News</a></li>
<li id="menu-item-532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532"><a href="https://www.vaughantoday.ca/world/">World</a></li>
<li id="menu-item-533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533"><a href="https://www.vaughantoday.ca/economy/">Economy</a></li>
<li id="menu-item-534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-534"><a href="https://www.vaughantoday.ca/science/">Science and Health</a></li>
<li id="menu-item-535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-535"><a href="https://www.vaughantoday.ca/tech/">Technology</a></li>
<li id="menu-item-536" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-536"><a href="https://www.vaughantoday.ca/sport/">sport</a></li>
<li id="menu-item-537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537"><a href="https://www.vaughantoday.ca/entertainment/">entertainment</a></li>
<li id="menu-item-10725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10725"><a href="https://www.vaughantoday.ca/contact-form/">Contact Form</a></li>
</ul>						</div><!-- #site-navigation .main-navigation -->
					</div><!-- .navbar-collapse -->
				</div><!-- .navbar-main -->
							</div><!-- .navbar-header-container -->
		</nav><!-- .navbar -->

		
					<div id="breadcrumb">
				<div class="container">
					<div role="navigation" aria-label="Breadcrumbs" class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb"><ul class="trail-items" itemscope itemtype="http://schema.org/BreadcrumbList"><meta name="numberOfItems" content="3" /><meta name="itemListOrder" content="Ascending" /><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-begin"><a href="https://www.vaughantoday.ca" rel="home" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item"><a href="https://www.vaughantoday.ca/sport/" itemprop="item"><span itemprop="name">sport</span></a><meta itemprop="position" content="2" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-end"><span itemprop="name">Guy LaFleur&#8217;s 70th birthday</span><meta itemprop="position" content="3" /></li></ul></div>				</div>
			</div><!-- .breadcrumb -->
			</header><!-- #masthead -->
	<div id="content" class="site-content">
					<div class="container">
				<div class="row justify-content-center site-content-row">
		<div id="primary" class="col-lg-8 content-area">		<main id="main" class="site-main">

				<div class="post-15980 post type-post status-publish format-standard has-post-thumbnail hentry category-sport">

		
					<figure class="post-featured-image page-single-img-wrap">
						<div data-bg="https://www.vaughantoday.ca/wp-content/uploads/2021/09/Guy-LaFleurs-70th-birthday.jpg" class="post-img rocket-lazyload" style=""></div>
					</figure><!-- .post-featured-image .page-single-img-wrap -->

				
				<div class="entry-meta category-meta">
					<div class="cat-links">
				<a class="cat-links-23" href="https://www.vaughantoday.ca/sport/">sport</a>
			</div>
				</div><!-- .entry-meta -->

			
					<header class="entry-header">
				<h1 class="entry-title">Guy LaFleur&#8217;s 70th birthday</h1>
									<div class="entry-meta">
						<div class="date"><a href="https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/" title="Guy LaFleur&#8217;s 70th birthday">September 19, 2021</a> </div> <div class="by-author vcard author"><a href="https://www.vaughantoday.ca/author/reyansh/">Virginia Whitehead</a> </div>											</div><!-- .entry-meta -->
								</header>
		
			<div class="entry-content">
				
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="d1010f327ba2c3c93041ebcc4f90ff15" data-index="1" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Dello Responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-9373527821382765"
     data-ad-slot="7916102596"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div id="StoryDetailBody61468d432629af08fc5b4b81">
<p> <strong>Guy LaFleur can&#8217;t believe it.  He celebrates his 70th birthday tomorrow.  Like everyone else growing up, he can&#8217;t believe it.  A chic from Denis Botvin won&#8217;t shake him up anymore.  This is the reality, however.</strong></p>
<p>&#8220;I haven&#8217;t seen anything,&#8221; he says to me, &#8220;the years have passed, I&#8217;ll tell you.&#8221; </p>
<p>&#8220;Tapuer, this doesn&#8217;t make sense!&#8221;  &#8220;</p>
<p>Lafleur is watching the movie of his life.</p>
<p>&#8220;In this age we&#8217;re in, we tend to look more at what we&#8217;ve done than what&#8217;s going to happen. We don&#8217;t know what gets stuck at the end of the nose.</p>
<p>“The past, at least, is tangible. The future, you cannot look far ahead. You have to take the days one by one, and no more.</p>
<p>“In my case, I can&#8217;t plan long term.”</p>
<p><span style="color: rgb(7,147,170);"><strong>A new form of treatment</strong></span></p>
<p>His health has been damaged in recent years, as we all know.</p>
<p>LaFleur is fighting lung cancer with the same determination and desire that marked him on the ice.</p>
<p>His voice is good.</p>
<p>At the beginning of October, he will undergo a new form of treatment.  His doctor told him he would feel more tired.</p>
<p>&#8220;I&#8217;m going to lose my hair, but that&#8217;s okay,&#8221; he adds.</p>
<p>“As long as the results are positive, that&#8217;s all that matters.”</p>
<p>He is busy going to restaurants with friends and working around his house as Lac des Deux-Montagnes gives him a great view of nature.</p>
<p><span style="color: rgb(7,147,170);"><strong>Head full of memories</strong></span></p>
<p>Like any athlete, Lafleur lived his career without stopping for his exploits.  He didn&#8217;t have time for that. </p>
<p>What he had in mind was the next win, the next Stanley Cup.  He took over his job, thirst for victory, and enjoyed the hockey environment of the time.</p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://www.vaughantoday.ca/a-special-glove-for-jeff-petrie/" target="_blank" rel="dofollow" class="u1146076705f0cd526abf5cdf49f67c05"><!-- INLINE RELATED POSTS 1/3 //--><style> .u1146076705f0cd526abf5cdf49f67c05 { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:inherit; border:0!important; border-left:4px solid inherit!important; text-decoration:none; } .u1146076705f0cd526abf5cdf49f67c05:active, .u1146076705f0cd526abf5cdf49f67c05:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .u1146076705f0cd526abf5cdf49f67c05 { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .u1146076705f0cd526abf5cdf49f67c05 .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .u1146076705f0cd526abf5cdf49f67c05 .postTitle { color:inherit; text-decoration: underline!important; font-size: 16px; } .u1146076705f0cd526abf5cdf49f67c05:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">See also</span>&nbsp; <span class="postTitle">A special glove for Jeff Petrie</span></div></a></div><p>&#8220;Today, I realized what my life has been like for the past 50 years,&#8221; he says.</p>
<div class="photo-inline">
<div class="espacePhoto">
                <a target="_blank" class="fancybox" rel="group noopener" href="https://m1.quebecormedia.com/emp/emp/40418037_378552da4c796a-6698-4f3b-ae06-2cd20b17bf06_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=16&amp;w=494&amp;h=570&amp;width=1200"></p>
<p>                  <span class="icon-zoom"/>
                  <picture><!--[if IE 9]><video style="display: none;"><![endif]--><source data-srcset="https://m1.quebecormedia.com/emp/emp/40418037_378552da4c796a-6698-4f3b-ae06-2cd20b17bf06_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=16&amp;w=494&amp;h=570&amp;width=968,&#10;                                    https://m1.quebecormedia.com/emp/emp/40418037_378552da4c796a-6698-4f3b-ae06-2cd20b17bf06_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=16&amp;w=494&amp;h=570&amp;width=1936 2x" media="(min-width: 40em)"><!--[if IE 9]></video><![endif]--><img srcset="https://m1.quebecormedia.com/emp/emp/40418037_378552da4c796a-6698-4f3b-ae06-2cd20b17bf06_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=16&amp;w=494&amp;h=570&amp;width=480,&#10;                                    https://m1.quebecormedia.com/emp/emp/40418037_378552da4c796a-6698-4f3b-ae06-2cd20b17bf06_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=16&amp;w=494&amp;h=570&amp;width=960 2x" data-aspect-ratio="auto" data-width="" class="story-img lazyload" itemprop="thumbnailUrl" alt="Between 1962 and 1964, Guy Lafleur stole the show at the Quebec International Pee-Wee Championships where he scored 64 goals."/></source></picture></a></p>
<div class="image-information">
<p>                    Photo Archive
                  </p>
<p>                    Between 1962 and 1964, Guy Lafleur stole the show at the Quebec International Pee-Wee Championships where he scored 64 goals.
                  </p>
</p></div>
</p></div>
</p></div>
<p>“I find it interesting to have the opportunity to do this, review my life, remember good and bad memories, and learn lessons that allow me to have a better quality of life.”</p>
<p>Special memories come back to him.</p>
<div class="photo-inline">
<div class="espacePhoto">
                <a target="_blank" class="fancybox" rel="group noopener" href="https://m1.quebecormedia.com/emp/emp/5408836526d54a1c-1e90-48ce-b7dd-af0920e5b726_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=2000&amp;h=1127&amp;width=1200"></p>
<p>                  <span class="icon-zoom"/>
                  <picture><!--[if IE 9]><video style="display: none;"><![endif]--><source data-srcset="https://m1.quebecormedia.com/emp/emp/5408836526d54a1c-1e90-48ce-b7dd-af0920e5b726_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=2000&amp;h=1127&amp;width=968,&#10;                                    https://m1.quebecormedia.com/emp/emp/5408836526d54a1c-1e90-48ce-b7dd-af0920e5b726_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=2000&amp;h=1127&amp;width=1936 2x" media="(min-width: 40em)"><!--[if IE 9]></video><![endif]--><img srcset="https://m1.quebecormedia.com/emp/emp/5408836526d54a1c-1e90-48ce-b7dd-af0920e5b726_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=2000&amp;h=1127&amp;width=480,&#10;                                    https://m1.quebecormedia.com/emp/emp/5408836526d54a1c-1e90-48ce-b7dd-af0920e5b726_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=2000&amp;h=1127&amp;width=960 2x" data-aspect-ratio="auto" data-width="" class="story-img lazyload" itemprop="thumbnailUrl" alt="The fourth issue of the Rembars family who celebrated the conquest of the Memorial Cup in May 1971."/></source></picture></a></p>
<div class="image-information">
<p>                    Photo Archive
                  </p>
<p>                    The fourth issue of the Rembars family who celebrated the conquest of the Memorial Cup in May 1971.
                  </p>
</p></div>
</p></div>
</p></div>
<p>“The Quebec Pew, the Remparts and the Draft That Led Me to Canadians,” he quotes.</p>
<p>“My first getaway is a part of that too. These episodes have been some of the highlights of my career.”</p>
<p><span style="color: rgb(7,147,170);"><strong>Always a big mail</strong></span></p>
<p>Amateurs don&#8217;t forget him.  He receives mail every day.  Letters are sent to him from Europe and even Asia.</p>
<p>Others are from Las Vegas, something LaFleur hadn&#8217;t seen before the National League moved to Sin City.  Seattle is expected to join the group soon.  </p>
<p>Once a week, he devotes about two hours to his mail.  His heart is thrilled to see that fans continue to write to him 30 years after his second withdrawal from the competition.</p>
<p>&#8220;She survives,&#8221; he said.</p>
<div class="photo-inline">
<div class="espacePhoto">
                <a target="_blank" class="fancybox" rel="group noopener" href="https://m1.quebecormedia.com/emp/emp/40195072_378551827cdd4f-d7fe-4ddf-8425-a22ddd2f0fe9_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=2000&amp;h=1164&amp;width=1200"></p>
<p>                  <span class="icon-zoom"/>
                  <picture><!--[if IE 9]><video style="display: none;"><![endif]--><source data-srcset="https://m1.quebecormedia.com/emp/emp/40195072_378551827cdd4f-d7fe-4ddf-8425-a22ddd2f0fe9_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=2000&amp;h=1164&amp;width=968,&#10;                                    https://m1.quebecormedia.com/emp/emp/40195072_378551827cdd4f-d7fe-4ddf-8425-a22ddd2f0fe9_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=2000&amp;h=1164&amp;width=1936 2x" media="(min-width: 40em)"><!--[if IE 9]></video><![endif]--><img srcset="https://m1.quebecormedia.com/emp/emp/40195072_378551827cdd4f-d7fe-4ddf-8425-a22ddd2f0fe9_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=2000&amp;h=1164&amp;width=480,&#10;                                    https://m1.quebecormedia.com/emp/emp/40195072_378551827cdd4f-d7fe-4ddf-8425-a22ddd2f0fe9_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=2000&amp;h=1164&amp;width=960 2x" data-aspect-ratio="auto" data-width="" class="story-img lazyload" itemprop="thumbnailUrl" alt="Gary Carter and Jay LaFleur, champions of the Montreal sports scene."/></source></picture></a></p>
<div class="image-information">
<p>                    Photo Archive
                  </p>
<p>                    Gary Carter and Jay LaFleur, champions of the Montreal sports scene.
                  </p>
</p></div>
</p></div>
</p></div>
<p>&#8220;I&#8217;ve been asked to sign pictures, T-shirts and pucks. Most of these people then sell these items, but I don&#8217;t mind.</p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://www.vaughantoday.ca/womens-hockey-world-cup-the-canadian-team-is-still-undefeated-in-calgary/" target="_blank" rel="dofollow" class="u07a172f28ef450805b413f30245a8afc"><!-- INLINE RELATED POSTS 2/3 //--><style> .u07a172f28ef450805b413f30245a8afc { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:inherit; border:0!important; border-left:4px solid inherit!important; text-decoration:none; } .u07a172f28ef450805b413f30245a8afc:active, .u07a172f28ef450805b413f30245a8afc:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .u07a172f28ef450805b413f30245a8afc { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .u07a172f28ef450805b413f30245a8afc .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .u07a172f28ef450805b413f30245a8afc .postTitle { color:inherit; text-decoration: underline!important; font-size: 16px; } .u07a172f28ef450805b413f30245a8afc:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">See also</span>&nbsp; <span class="postTitle">Women's Hockey World Cup | The Canadian team is still undefeated in Calgary</span></div></a></div><p>My name and photo continue to spread.  He will fall dead the day he does not happen again.  There comes a time when people don&#8217;t know what you&#8217;ve done.</p>
<p>“I still think I will be present in the collective memory for a while now. There are still generations who watched me play and future generations will speak of me again.”</p>
<p><span style="color: rgb(7,147,170);"><strong>Eternal Mauritius</strong></span></p>
<p>Think of Maurice Richard.</p>
<p>In a 1971 documentary directed by Jill Gascon and produced by the National Film Board, Rocket said it would be funny for him not to be recognized on the street for the next 10 to 15 years.</p>
<p>However.</p>
<p>&#8220;If we continue to talk about him today, it is because there are still many journalists who know his time,&#8221; LaFleur explains.</p>
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="d1010f327ba2c3c93041ebcc4f90ff15" data-index="2" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Dello Responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-9373527821382765"
     data-ad-slot="7916102596"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<p>“Will it be the same in 20 or 30 years?”  Will journalists talk about us again?  He adds, speaking for himself and the other greats of his generation. </p>
<p>“We may replace our statues at the Bell Center with ones like the ghosts of the Forum.”</p>
<p>We can easily spot Lafleur&#8217;s humor here, but the statues of Howie Morenz, Maurice Richard, Jean Béliveau, and Lafleur are here to stay. </p>
<p>We will not be able to unravel them from their base.  These characters did not commit moral crimes.</p>
<p>These are legends who lived a good life.</p>
<p><span style="color: rgb(7,147,170);"><strong>In the right place at the right time</strong></span></p>
<p>LaFleur considers himself fortunate to have worked in the decades from 1960 to 1990.</p>
<p>&#8220;We had the advantage of playing at a time when hockey was really unusual,&#8221; says Lafleur.</p>
<div class="photo-inline">
<div class="espacePhoto">
                <a target="_blank" class="fancybox" rel="group noopener" href="https://m1.quebecormedia.com/emp/emp/54089565bedcf4d2-5ee3-401b-9afd-81341d08076a_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1365&amp;h=963&amp;width=1200"></p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://www.vaughantoday.ca/chs-final-joke-challenge-feeds-3200-homeless-people/" target="_blank" rel="dofollow" class="uf0bf5cad6a5308a66eabe9010741eac9"><!-- INLINE RELATED POSTS 3/3 //--><style> .uf0bf5cad6a5308a66eabe9010741eac9 { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:inherit; border:0!important; border-left:4px solid inherit!important; text-decoration:none; } .uf0bf5cad6a5308a66eabe9010741eac9:active, .uf0bf5cad6a5308a66eabe9010741eac9:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .uf0bf5cad6a5308a66eabe9010741eac9 { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .uf0bf5cad6a5308a66eabe9010741eac9 .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .uf0bf5cad6a5308a66eabe9010741eac9 .postTitle { color:inherit; text-decoration: underline!important; font-size: 16px; } .uf0bf5cad6a5308a66eabe9010741eac9:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">See also</span>&nbsp; <span class="postTitle">CH's Final: Joke Challenge Feeds 3,200 Homeless People</span></div></a></div><p>                  <span class="icon-zoom"/>
                  <picture><!--[if IE 9]><video style="display: none;"><![endif]--><source data-srcset="https://m1.quebecormedia.com/emp/emp/54089565bedcf4d2-5ee3-401b-9afd-81341d08076a_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1365&amp;h=963&amp;width=968,&#10;                                    https://m1.quebecormedia.com/emp/emp/54089565bedcf4d2-5ee3-401b-9afd-81341d08076a_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1365&amp;h=963&amp;width=1936 2x" media="(min-width: 40em)"><!--[if IE 9]></video><![endif]--><img srcset="https://m1.quebecormedia.com/emp/emp/54089565bedcf4d2-5ee3-401b-9afd-81341d08076a_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1365&amp;h=963&amp;width=480,&#10;                                    https://m1.quebecormedia.com/emp/emp/54089565bedcf4d2-5ee3-401b-9afd-81341d08076a_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1365&amp;h=963&amp;width=960 2x" data-aspect-ratio="auto" data-width="" class="story-img lazyload" itemprop="thumbnailUrl" alt="From 1971 to 1984, Lafleur shook the Forum Rays with CH."/></source></picture></a></p>
<div class="image-information">
<p>                    Getty Images
                  </p>
<p>                    From 1971 to 1984, Lafleur shook the Forum Rays with CH.
                  </p>
</p></div>
</p></div>
</p></div>
<p>“I think those were the best years of the National League. I knew players like Morris and Henry Richard, who I played with, Elmer Lash, Bobby Russo, Uriel Goliath, and others who fought to build the Canadian dynasty.</p>
<p>“For those of us who followed, it was important to win and carry on the winning tradition our ancestors created.”</p>
<div class="photo-inline">
<div class="espacePhoto">
                <a target="_blank" class="fancybox" rel="group noopener" href="https://m1.quebecormedia.com/emp/emp/43300783_3785494b168142-d7df-4716-ba54-f2686b1ee9d4_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1833&amp;h=1525&amp;width=1200"></p>
<p>                  <span class="icon-zoom"/>
                  <picture><!--[if IE 9]><video style="display: none;"><![endif]--><source data-srcset="https://m1.quebecormedia.com/emp/emp/43300783_3785494b168142-d7df-4716-ba54-f2686b1ee9d4_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1833&amp;h=1525&amp;width=968,&#10;                                    https://m1.quebecormedia.com/emp/emp/43300783_3785494b168142-d7df-4716-ba54-f2686b1ee9d4_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1833&amp;h=1525&amp;width=1936 2x" media="(min-width: 40em)"><!--[if IE 9]></video><![endif]--><img srcset="https://m1.quebecormedia.com/emp/emp/43300783_3785494b168142-d7df-4716-ba54-f2686b1ee9d4_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1833&amp;h=1525&amp;width=480,&#10;                                    https://m1.quebecormedia.com/emp/emp/43300783_3785494b168142-d7df-4716-ba54-f2686b1ee9d4_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1833&amp;h=1525&amp;width=960 2x" data-aspect-ratio="auto" data-width="" class="story-img lazyload" itemprop="thumbnailUrl" alt="Zahra came out of retirement to play for the New York Rangers for the 1988-1989 campaign."/></source></picture></a></p>
<div class="image-information">
<p>                    photo courtesy
                  </p>
<p>                    Zahra came out of retirement to play for the New York Rangers for the 1988-1989 campaign.
                  </p>
</p></div>
</p></div>
</p></div>
<p>The Quebec players were proud to play for the Canadians and as LaFleur pointed out, there were some great players.</p>
<p>And it wasn&#8217;t about the money.</p>
<div class="photo-inline">
<div class="espacePhoto">
                <a target="_blank" class="fancybox" rel="group noopener" href="https://m1.quebecormedia.com/emp/emp/43300784_378550c814aece-81aa-47d4-af1a-6b3b37d3adcb_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1601&amp;h=1475&amp;width=1200"></p>
<p>                  <span class="icon-zoom"/>
                  <picture><!--[if IE 9]><video style="display: none;"><![endif]--><source data-srcset="https://m1.quebecormedia.com/emp/emp/43300784_378550c814aece-81aa-47d4-af1a-6b3b37d3adcb_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1601&amp;h=1475&amp;width=968,&#10;                                    https://m1.quebecormedia.com/emp/emp/43300784_378550c814aece-81aa-47d4-af1a-6b3b37d3adcb_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1601&amp;h=1475&amp;width=1936 2x" media="(min-width: 40em)"><!--[if IE 9]></video><![endif]--><img srcset="https://m1.quebecormedia.com/emp/emp/43300784_378550c814aece-81aa-47d4-af1a-6b3b37d3adcb_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1601&amp;h=1475&amp;width=480,&#10;                                    https://m1.quebecormedia.com/emp/emp/43300784_378550c814aece-81aa-47d4-af1a-6b3b37d3adcb_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1601&amp;h=1475&amp;width=960 2x" data-aspect-ratio="auto" data-width="" class="story-img lazyload" itemprop="thumbnailUrl" alt="The legendary No.10 player played for two seasons with Nordic, including his last lap in 1991."/></source></picture></a></p>
<div class="image-information">
<p>                    photo courtesy
                  </p>
<p>                    The legendary No.10 player played for two seasons with Nordic, including his last lap in 1991.
                  </p>
</p></div>
</p></div>
</p></div>
<p>&#8220;Hockey has always been a business, but it used to be more for the owners than the players,&#8221; says Lafleur.</p>
<p>“We had fun, we did everything to win as many matches as possible. We were excited. There was a lot of sympathy between the players. We weren&#8217;t a team, we were a family.”</p>
<div class="photo-inline">
<div class="espacePhoto">
                <a target="_blank" class="fancybox" rel="group noopener" href="https://m1.quebecormedia.com/emp/emp/20256603_378553f7d3c028-f06d-48eb-a376-09e6df95fd97_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1755&amp;h=1621&amp;width=1200"></p>
<p>                  <span class="icon-zoom"/>
                  <picture><!--[if IE 9]><video style="display: none;"><![endif]--><source data-srcset="https://m1.quebecormedia.com/emp/emp/20256603_378553f7d3c028-f06d-48eb-a376-09e6df95fd97_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1755&amp;h=1621&amp;width=968,&#10;                                    https://m1.quebecormedia.com/emp/emp/20256603_378553f7d3c028-f06d-48eb-a376-09e6df95fd97_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1755&amp;h=1621&amp;width=1936 2x" media="(min-width: 40em)"><!--[if IE 9]></video><![endif]--><img srcset="https://m1.quebecormedia.com/emp/emp/20256603_378553f7d3c028-f06d-48eb-a376-09e6df95fd97_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1755&amp;h=1621&amp;width=480,&#10;                                    https://m1.quebecormedia.com/emp/emp/20256603_378553f7d3c028-f06d-48eb-a376-09e6df95fd97_ORIGINAL.jpg?impolicy=crop-resize&amp;x=0&amp;y=0&amp;w=1755&amp;h=1621&amp;width=960 2x" data-aspect-ratio="auto" data-width="" class="story-img lazyload" itemprop="thumbnailUrl" alt="Former Canadian coach Scotty Bowman has always praised the blond devil."/></source></picture></a></p>
<div class="image-information">
<p>                    Photo Archive
                  </p>
<p>                    Former Canadian coach Scotty Bowman has always praised the blond devil.
                  </p>
</p></div>
</p></div>
</p></div>
<p>Do not believe that Lafleur is bitter and sad.  It&#8217;s not his style.</p>
<p>All he wants is better health.  It is the blessing we wish him.</p>
<p>Happy birthday, guy!</p>
<h3>To see also&#8230; </h3>
</p></div>
<p></p>

<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="d1010f327ba2c3c93041ebcc4f90ff15" data-index="3" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Dello Responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-9373527821382765"
     data-ad-slot="7916102596"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div><div class="saboxplugin-wrap" itemtype="http://schema.org/Person" itemscope itemprop="author"><div class="saboxplugin-tab"><div class="saboxplugin-gravatar"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" width="100"  height="100" alt="" itemprop="image" data-lazy-src="https://www.vaughantoday.ca/wp-content/uploads/2020/11/1-1.jpg"><noscript><img src="https://www.vaughantoday.ca/wp-content/uploads/2020/11/1-1.jpg" width="100"  height="100" alt="" itemprop="image"></noscript></div><div class="saboxplugin-authorname"><a href="https://www.vaughantoday.ca/author/reyansh/" class="vcard author" rel="author" itemprop="url"><span class="fn" itemprop="name">Virginia Whitehead</span></a></div><div class="saboxplugin-desc"><div itemprop="description"><p>&#8220;Pop culture maven. Unapologetic student. Avid introvert. Gamer. Problem solver. Tv fanatic.&#8221;</p>
</div></div><div class="clearfix"></div></div></div>			</div><!-- .entry-content -->

			</div><!-- .post-15980 -->

	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.vaughantoday.ca/all-games-announced-to-mark-thq-nordics-10th-anniversary/" rel="prev">All games announced to mark THQ Nordic&#8217;s 10th anniversary</a></div><div class="nav-next"><a href="https://www.vaughantoday.ca/friends-of-science-and-climate-an-ambitious-new-association/" rel="next">Friends of Science and Climate, an ambitious new association</a></div></div>
	</nav>
<div id="comments" class="comments-area">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/guy-lafleurs-70th-birthday/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.vaughantoday.ca/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='15980' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="fff454fe3f" /></p><input type="hidden" id="ak_js" name="ak_js" value="118"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	
</div><!-- #comments -->

		</main><!-- #main -->
	</div><!-- #primary -->


<aside id="secondary" class="col-lg-4 widget-area" role="complementary">
	<div class="sticky-sidebar">
		
<!-- Quick Adsense Wordpress Plugin: http://quickadsense.com/ -->
<section id="adswidget1-quick-adsense-2" class="widget widget_adswidget1-quick-adsense"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Dello Responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-9373527821382765"
     data-ad-slot="7916102596"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></section><section id="nav_menu-2" class="widget widget_nav_menu"><h3 class="widget-title">Navigate</h3><div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-530"><a href="https://www.vaughantoday.ca">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-531"><a href="https://www.vaughantoday.ca/top-news/">Top News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532"><a href="https://www.vaughantoday.ca/world/">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533"><a href="https://www.vaughantoday.ca/economy/">Economy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-534"><a href="https://www.vaughantoday.ca/science/">Science and Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-535"><a href="https://www.vaughantoday.ca/tech/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-536"><a href="https://www.vaughantoday.ca/sport/">sport</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537"><a href="https://www.vaughantoday.ca/entertainment/">entertainment</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10725"><a href="https://www.vaughantoday.ca/contact-form/">Contact Form</a></li>
</ul></div></section><section id="nav_menu-3" class="widget widget_nav_menu"><h3 class="widget-title">Pages</h3><div class="menu-secondary-menu-container"><ul id="menu-secondary-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2850"><a href="https://www.vaughantoday.ca/about-us/">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2849"><a href="https://www.vaughantoday.ca/dmca/">DMCA</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2851"><a href="https://www.vaughantoday.ca/contact-form/">Contact Form</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-2873"><a href="https://www.vaughantoday.ca/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2848"><a href="https://www.vaughantoday.ca/editorial-policy/">Editorial Policy</a></li>
</ul></div></section>
<!-- Quick Adsense Wordpress Plugin: http://quickadsense.com/ -->
<section id="adswidget2-quick-adsense-2" class="widget widget_adswidget2-quick-adsense"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Dello Responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-9373527821382765"
     data-ad-slot="7916102596"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></section>	</div><!-- .sticky-sidebar -->
</aside><!-- #secondary -->
								</div><!-- row -->
			</div><!-- .container -->
			</div><!-- #content .site-content-->
			<footer id="colophon" class="site-footer" role="contentinfo">
			
				<section class="featured-stories">
										<div class="container">
													<div class="section-title-wrap">
								<h2 class="stories-title">Recommended</h2>
							</div><!-- .section-title-wrap -->
						
						
						<div class="row justify-content-center">
															<div class="col-sm-6 col-lg-3 post-col">
									<div class="post-boxed">
																					<div class="post-img-wrap">
												<a data-bg="https://www.vaughantoday.ca/wp-content/uploads/2021/09/Quebecers-rediscover-the-desire-to-go-on-a-trip.jpg" href="https://www.vaughantoday.ca/quebecers-rediscover-the-desire-to-go-on-a-trip/" class="post-img rocket-lazyload" style=""></a>
												<div class="entry-meta category-meta">
													<div class="cat-links">
				<a class="cat-links-20" href="https://www.vaughantoday.ca/economy/">Economy</a>
			</div>
												</div><!-- .entry-meta -->
											</div><!-- .post-img-wrap -->
																				<div class="post-content">
																						<h3 class="entry-title"><a href="https://www.vaughantoday.ca/quebecers-rediscover-the-desire-to-go-on-a-trip/">Quebecers rediscover the desire to go on a trip</a></h3>																							<div class="entry-meta">
													<div class="date"><a href="https://www.vaughantoday.ca/quebecers-rediscover-the-desire-to-go-on-a-trip/" title="Quebecers rediscover the desire to go on a trip">September 19, 2021</a> </div> <div class="by-author vcard author"><a href="https://www.vaughantoday.ca/author/vihaan/">Maria Gill</a> </div>												</div>
																					</div><!-- .post-content -->
									</div><!-- .post-boxed -->
								</div>
															<div class="col-sm-6 col-lg-3 post-col">
									<div class="post-boxed">
																					<div class="post-img-wrap">
												<a data-bg="https://www.vaughantoday.ca/wp-content/uploads/2021/09/Belfast-by-Kenneth-Branagh-wins-TIFF-Audience-Award.png" href="https://www.vaughantoday.ca/belfast-by-kenneth-branagh-wins-tiff-audience-award/" class="post-img rocket-lazyload" style=""></a>
												<div class="entry-meta category-meta">
													<div class="cat-links">
				<a class="cat-links-24" href="https://www.vaughantoday.ca/entertainment/">entertainment</a>
			</div>
												</div><!-- .entry-meta -->
											</div><!-- .post-img-wrap -->
																				<div class="post-content">
																						<h3 class="entry-title"><a href="https://www.vaughantoday.ca/belfast-by-kenneth-branagh-wins-tiff-audience-award/">Belfast, by Kenneth Branagh, wins TIFF Audience Award</a></h3>																							<div class="entry-meta">
													<div class="date"><a href="https://www.vaughantoday.ca/belfast-by-kenneth-branagh-wins-tiff-audience-award/" title="Belfast, by Kenneth Branagh, wins TIFF Audience Award">September 19, 2021</a> </div> <div class="by-author vcard author"><a href="https://www.vaughantoday.ca/author/muhammad/">Tony Vaughn</a> </div>												</div>
																					</div><!-- .post-content -->
									</div><!-- .post-boxed -->
								</div>
															<div class="col-sm-6 col-lg-3 post-col">
									<div class="post-boxed">
																					<div class="post-img-wrap">
												<a data-bg="https://www.vaughantoday.ca/wp-content/uploads/2021/09/Friends-of-Science-and-Climate-an-ambitious-new-association.jpg" href="https://www.vaughantoday.ca/friends-of-science-and-climate-an-ambitious-new-association/" class="post-img rocket-lazyload" style=""></a>
												<div class="entry-meta category-meta">
													<div class="cat-links">
				<a class="cat-links-21" href="https://www.vaughantoday.ca/science/">science</a>
			</div>
												</div><!-- .entry-meta -->
											</div><!-- .post-img-wrap -->
																				<div class="post-content">
																						<h3 class="entry-title"><a href="https://www.vaughantoday.ca/friends-of-science-and-climate-an-ambitious-new-association/">Friends of Science and Climate, an ambitious new association</a></h3>																							<div class="entry-meta">
													<div class="date"><a href="https://www.vaughantoday.ca/friends-of-science-and-climate-an-ambitious-new-association/" title="Friends of Science and Climate, an ambitious new association">September 19, 2021</a> </div> <div class="by-author vcard author"><a href="https://www.vaughantoday.ca/author/vihaan/">Maria Gill</a> </div>												</div>
																					</div><!-- .post-content -->
									</div><!-- .post-boxed -->
								</div>
															<div class="col-sm-6 col-lg-3 post-col">
									<div class="post-boxed">
																					<div class="post-img-wrap">
												<a data-bg="https://www.vaughantoday.ca/wp-content/uploads/2021/09/Guy-LaFleurs-70th-birthday.jpg" href="https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/" class="post-img rocket-lazyload" style=""></a>
												<div class="entry-meta category-meta">
													<div class="cat-links">
				<a class="cat-links-23" href="https://www.vaughantoday.ca/sport/">sport</a>
			</div>
												</div><!-- .entry-meta -->
											</div><!-- .post-img-wrap -->
																				<div class="post-content">
																						<h3 class="entry-title"><a href="https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/">Guy LaFleur&#8217;s 70th birthday</a></h3>																							<div class="entry-meta">
													<div class="date"><a href="https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/" title="Guy LaFleur&#8217;s 70th birthday">September 19, 2021</a> </div> <div class="by-author vcard author"><a href="https://www.vaughantoday.ca/author/reyansh/">Virginia Whitehead</a> </div>												</div>
																					</div><!-- .post-content -->
									</div><!-- .post-boxed -->
								</div>
													</div><!-- .row .owl-carousel-->
											</div><!-- .container -->
														</section><!-- .featured-stories -->
			
			
				<div class="widget-area">
					<div class="container">
						<div class="row">
							<div class="col-sm-6 col-lg-4">
								<section id="pages-3" class="widget widget_pages"><h3 class="widget-title">Pages</h3>
			<ul>
				<li class="page_item page-item-413"><a href="https://www.vaughantoday.ca/about-us/">About Us</a></li>
<li class="page_item page-item-412"><a href="https://www.vaughantoday.ca/contact-form/">Contact Form</a></li>
<li class="page_item page-item-415"><a href="https://www.vaughantoday.ca/dmca/">DMCA</a></li>
<li class="page_item page-item-2527"><a href="https://www.vaughantoday.ca/editorial-policy/">Editorial Policy</a></li>
<li class="page_item page-item-410"><a href="https://www.vaughantoday.ca/privacy-policy/">Privacy Policy</a></li>
			</ul>

			</section>							</div><!-- footer sidebar column 1 -->
							<div class="col-sm-6 col-lg-4">
								
		<section id="recent-posts-4" class="widget widget_recent_entries">
		<h3 class="widget-title">Recent Posts</h3>
		<ul>
											<li>
					<a href="https://www.vaughantoday.ca/quebecers-rediscover-the-desire-to-go-on-a-trip/">Quebecers rediscover the desire to go on a trip</a>
									</li>
											<li>
					<a href="https://www.vaughantoday.ca/belfast-by-kenneth-branagh-wins-tiff-audience-award/">Belfast, by Kenneth Branagh, wins TIFF Audience Award</a>
									</li>
											<li>
					<a href="https://www.vaughantoday.ca/friends-of-science-and-climate-an-ambitious-new-association/">Friends of Science and Climate, an ambitious new association</a>
									</li>
											<li>
					<a href="https://www.vaughantoday.ca/guy-lafleurs-70th-birthday/" aria-current="page">Guy LaFleur&#8217;s 70th birthday</a>
									</li>
											<li>
					<a href="https://www.vaughantoday.ca/all-games-announced-to-mark-thq-nordics-10th-anniversary/">All games announced to mark THQ Nordic&#8217;s 10th anniversary</a>
									</li>
					</ul>

		</section>							</div><!-- footer sidebar column 2 -->
															<div class="col-sm-6 col-lg-4">
									<section id="nav_menu-5" class="widget widget_nav_menu"><div class="menu-primary-menu-container"><ul id="menu-primary-menu-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-530"><a href="https://www.vaughantoday.ca">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-531"><a href="https://www.vaughantoday.ca/top-news/">Top News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532"><a href="https://www.vaughantoday.ca/world/">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533"><a href="https://www.vaughantoday.ca/economy/">Economy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-534"><a href="https://www.vaughantoday.ca/science/">Science and Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-535"><a href="https://www.vaughantoday.ca/tech/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-536"><a href="https://www.vaughantoday.ca/sport/">sport</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537"><a href="https://www.vaughantoday.ca/entertainment/">entertainment</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10725"><a href="https://www.vaughantoday.ca/contact-form/">Contact Form</a></li>
</ul></div></section>								</div><!-- footer sidebar column 3 -->
														</div><!-- .row -->
					</div><!-- .container -->
				</div><!-- .widget-area -->
			
							<div class="site-info">
					<div class="container">
						<div class="row">
															<div class="copyright col-lg order-lg-1 text-lg-left">
																			<div class="theme-link">
											Copyright &copy; 2021 <a href="https://www.vaughantoday.ca/" title="Vaughan Today" >Vaughan Today</a></div><div class="privacy-link"><a class="privacy-policy-link" href="https://www.vaughantoday.ca/privacy-policy/">Privacy Policy</a></div>								</div><!-- .copyright -->
													</div><!-- .row -->
					</div><!-- .container -->
				</div><!-- .site-info -->
					</footer><!-- #colophon -->
		<div class="back-to-top"><a title="Go to Top" href="#masthead"></a></div>
</div><!-- #page -->

<script type="text/javascript">var jQueryScriptOutputted = false;function initJQuery() {if (typeof(jQuery) == "undefined") {if (!jQueryScriptOutputted) {jQueryScriptOutputted = true;document.write("<scr" + "ipt type=\"text/javascript\" src=\"https://code.jquery.com/jquery-1.8.2.min.js\"></scr" + "ipt>");}setTimeout("initJQuery()", 50);}}initJQuery();</script><script type="text/javascript">window.addEventListener('DOMContentLoaded', function() {jQuery(document).ready(function() {
jQuery(".d1010f327ba2c3c93041ebcc4f90ff15").click(function() {
jQuery.post(
"https://www.vaughantoday.ca/wp-admin/admin-ajax.php", {
"action": "quick_adsense_onpost_ad_click",
"quick_adsense_onpost_ad_index": jQuery(this).attr("data-index"),
"quick_adsense_nonce": "7dde964ae7",
}, function(response) { }
);
});
});
});</script>














<script type='text/javascript' id='fifu-image-js-js-extra'>
/* <![CDATA[ */
var fifuImageVars = {"fifu_lazy":"","fifu_woo_lbox_enabled":"1","fifu_woo_zoom":"inline","fifu_is_product":"","fifu_is_flatsome_active":"","fifu_rest_url":"https:\/\/www.vaughantoday.ca\/wp-json\/","fifu_nonce":"8e50a901cc"};
/* ]]> */
</script>


<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.vaughantoday.ca/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>
<script src="https://www.vaughantoday.ca/wp-content/cache/min/1/eea1ee921023c8d1f9916ebff2adfde6.js" data-minify="1" defer></script></body>
</html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->